Sisyphus repository
Last update: 20 june 2019 | SRPMs: 17673 | Visits: 14147838
en ru br
ALT Linux repos
S:5.2.26-alt3
5.0: 3.0.4-alt0.M50.1
4.1: 2.1.4-alt0.M41.5
4.0:
+backports:1.6.6-alt0.M40.2

Group :: Emulators
RPM: virtualbox

 Main   Changelog   Spec   Patches   Sources   Download   Gear   Bugs and FR  Repocop 

Patch: virtualbox-system-yasm.diff
Download


--- Config.kmk
+++ Config.kmk
@@ -861,7 +861,7 @@
 # We need to export YASM for OSE, but since it was converted to .zip we need to
 # allow for the location used by the zip to be properly cleaned up first.
 if1of ($(KBUILD_HOST).$(KBUILD_HOST_ARCH),  win.x86 linux.x86 solaris.x86)
- PATH_TOOL_YASM ?= $(PATH_DEVTOOLS_BLD)/bin
+ PATH_TOOL_YASM ?= /usr/bin
 endif
 
 # XPCOM setup for all but win32.
--- configure
+++ configure
@@ -468,8 +468,8 @@
       yasm_min=`echo $yasm_ver|cut -d. -f2`
       yasm_rev=`echo $yasm_ver|cut -d. -f3`
       yasm_ver_mul=`expr $yasm_maj \* 10000 + $yasm_min \* 100 + $yasm_rev`
-      if [ $yasm_ver_mul -lt 501 ]; then
-        log_failure "found version $yasm_ver, expected at least 0.5.1"
+      if [ $yasm_ver_mul -lt 600 ]; then
+        log_failure "found version $yasm_ver, expected at least 0.6.0"
         fail
       else
         log_success "found version $yasm_ver"
@@ -1503,7 +1503,7 @@
 [ "$OS" != "darwin"  ] && check_bcc
 [ "$OS" != "darwin"  ] && check_iasl
 # don't check for yasm for the time beeing as 0.40 and 0.50 both have known bugs
-# [ "$OS" != "darwin" ] && check_yasm
+[ "$OS" != "darwin" ] && check_yasm
 [ "$OS" != "darwin"  ] && check_xsltproc
 [ $OSE -eq 0 ]         && check_mkisofs
 
 
design & coding: Vladimir Lettiev aka crux © 2004-2005, Andrew Avramenko aka liks © 2007-2008
current maintainer: Michael Shigorin