Репозиторий Sisyphus
Последнее обновление: 13 октября 2019 | Пакетов: 17515 | Посещений: 15263930
en ru br
Репозитории ALT

Группа :: Other
Пакет: xrootd

 Главная   Изменения   Спек   Патчи   Sources   Загрузить   Gear   Bugs and FR  Repocop 


id пакета статус тест сообщение
xrootd-4.9.1-alt1.x86_64
info
altlinux-policy-shared-lib-contains-devel-so SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libXrdAppUtils.so but just /usr/lib64/libXrdAppUtils.so.1.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libXrdAppUtils.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libXrdAppUtils.so to \%files of xrootd-4.9.1-alt1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test. SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libXrdCl.so but just /usr/lib64/libXrdCl.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libXrdCl.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib
xrootd-devel-4.9.1-alt1.x86_64
info
altlinux-policy-shared-lib-contains-devel-so SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libXrdCryptoLite.so but just /usr/lib64/libXrdCryptoLite.so.1.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libXrdCryptoLite.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libXrdCryptoLite.so to \%files of xrootd-devel-4.9.1-alt1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test. SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libXrdHttpUtils.so but just /usr/lib64/libXrdHttpUtils.so.1.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libXrdHttpUtils.so should be placed in a special subpackage named lib-devel. If you have alre... [the rest of the message is skipped]
xrootd-4.9.1-alt1.x86_64
info
beehive-log-unpackaged-files-found-i586 warning: Installed (but unpackaged) file(s) found: /usr/lib/libXrdHttpTPC-4.so
xrootd-4.9.1-alt1.x86_64
info
beehive-log-unpackaged-files-found-x86_64 warning: Installed (but unpackaged) file(s) found: /usr/lib64/libXrdHttpTPC-4.so
xrootd-4.9.1-alt1.x86_64
ok
checkbashisms
xrootd-4.9.1-alt1.x86_64
ok
buildroot
xrootd-4.9.1-alt1.x86_64
ok
unsafe-tmp-usage-in-scripts
xrootd-4.9.1-alt1.x86_64
ok
sisyphus_check
xrootd-debuginfo-4.9.1-alt1.x86_64
ok
checkbashisms
xrootd-debuginfo-4.9.1-alt1.x86_64
ok
buildroot
xrootd-debuginfo-4.9.1-alt1.x86_64
ok
unsafe-tmp-usage-in-scripts
xrootd-debuginfo-4.9.1-alt1.x86_64
ok
sisyphus_check
xrootd-devel-4.9.1-alt1.x86_64
ok
checkbashisms
xrootd-devel-4.9.1-alt1.x86_64
ok
buildroot
xrootd-devel-4.9.1-alt1.x86_64
ok
unsafe-tmp-usage-in-scripts
xrootd-devel-4.9.1-alt1.x86_64
ok
sisyphus_check
xrootd-perl-4.9.1-alt1.x86_64
ok
checkbashisms
xrootd-perl-4.9.1-alt1.x86_64
ok
buildroot
xrootd-perl-4.9.1-alt1.x86_64
ok
unsafe-tmp-usage-in-scripts
xrootd-perl-4.9.1-alt1.x86_64
ok
sisyphus_check
xrootd-devel-debuginfo-4.9.1-alt1.x86_64
ok
checkbashisms
xrootd-devel-debuginfo-4.9.1-alt1.x86_64
ok
buildroot
xrootd-devel-debuginfo-4.9.1-alt1.x86_64
ok
unsafe-tmp-usage-in-scripts
xrootd-devel-debuginfo-4.9.1-alt1.x86_64
ok
sisyphus_check
 
дизайн и разработка: Vladimir Lettiev aka crux © 2004-2005, Andrew Avramenko aka liks © 2007-2008
текущий майнтейнер: Michael Shigorin